Formeln kopieren und Inhalte einfügen geht nicht mehr

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

skl
*
Beiträge: 10
Registriert: Fr, 29.01.2016 16:13

Formeln kopieren und Inhalte einfügen geht nicht mehr

Beitrag von skl » So, 15.04.2018 15:11

Seit heute verhält sich LO Calc sehr seltsam: Ich kann keine Formeln mehr kopieren! Beim Einfügen wird mit ctrl+v nur unformatierter Text eingefügt. ctrl+shft+v bietet mir nur "unformatierter Text" an, auch Rechtsklick->"Inhalte einfügen" liefert das selbe Ergebnis!

Kennt jemand das Problem??
Danke
Stefan

Stephan
********
Beiträge: 10435
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: Formeln kopieren und Inhalte einfügen geht nicht mehr

Beitrag von Stephan » Mo, 16.04.2018 08:21

skl hat geschrieben:
So, 15.04.2018 15:11
Seit heute verhält sich LO Calc sehr seltsam: Ich kann keine Formeln mehr kopieren! Beim Einfügen wird mit ctrl+v nur unformatierter Text eingefügt. ctrl+shft+v bietet mir nur "unformatierter Text" an, auch Rechtsklick->"Inhalte einfügen" liefert das selbe Ergebnis!

Kennt jemand das Problem??
Danke
Stefan
Dieses Problem ist mir nicht bekannt. Versuche es zu beseitigen indem Du das bestehende LO-Benutzerverzeichnis umbenennst:
http://de.openoffice.info/viewtopic.php ... 31#p206070


Gruß
Stephan

skl
*
Beiträge: 10
Registriert: Fr, 29.01.2016 16:13

Re: Formeln kopieren und Inhalte einfügen geht nicht mehr

Beitrag von skl » Mo, 16.04.2018 22:09

Hat leider nicht funktioniert. Wenn immer ich eine Formel kopieren will, wird nur der Wert eingefügt. Selbst wenn ich die Formel aus der Bearbeitungsleiste kopiere! Wenn ich sie ohne "=" kopiere wird zumindest die Formel eingefügt, aber die Bezüge nicht geändert. Eine Formel nach unten ausfüllen geht. Eine aus der ersten Zelle in die Nächste kopieren geht nicht, es wird nur der Wert eingefügt.
Ich bin ratlos!

Danke für gute Ideen
Stefan

PS: Jetzt habe ich das komplette Office mit purge deinstalliert und neu installiert. Ergebnis: der selbe Sch.... !!!!!!!!!!!!!!!!!!!!!!!! :evil: :evil: :evil:

Linux Mint 18.3 Cinnamon 64-bit, LO 6.0.3

paljass
******
Beiträge: 672
Registriert: Do, 25.10.2012 07:25

Re: Formeln kopieren und Inhalte einfügen geht nicht mehr

Beitrag von paljass » Di, 17.04.2018 06:36

Moin,
guck mal, ob unter Format-Zellen-Zellschutz ein Haken bei "Formeln ausblenden" gesetzt ist. Dann diesen entferne und schon klappts wieder mit dem Kopieren - hoffentlich 8)

Gruß
paljass
EDV ist wie U-Boot fahren - machst du ein Fenster auf, fangen die Probleme an.

JosuaKylie

Re: Formeln kopieren und Inhalte einfügen geht nicht mehr

Beitrag von JosuaKylie » So, 13.05.2018 08:42

Nun liebe LO-Gemeinde. Seit vielen Jahren benutze ich OO/LO-Calc statt Excel - und das bislang weitgehend problemlos (weitaus überwiegend diverseste Versionen unter Linux...). Doch seit ich LO-Calc - Version: 6.0.2.1 (x64) unter Win 10 verwende, muss ich mir permanent die Haare raufen, wozu der hier relevante Problemkreis erheblich - in meinem Fall sogar dramatisch - beiträgt.

Ich habe ungezählte Dateien mit Tabellen-Bereichen, in denen ich über recht komplexe Formeln (Zählen wenn etc. pp..) Zahlenwerte aus anderen Tabellen und Tabellenblättern für die Erstellung von Grafiken aufbereite, was an sich ohne Probleme korrekt funktioniert. Um insbesondere komplexere Grafiken unter allen Umständen reproduzieren zu können, lege ich zu diesen grundsätzlich Tabellenbereiche an, die nur die nackten Werte für die Darstellung enthalten.

Ich kann mich nicht erinnern, dass es JE ein Problem war, die im Formelbereich dargestellten Zahlenwerte der Ergebnisse durch Kopieren und Inhalte als Werte einfügen in den Bereich der Grafikdaten zu übertragen. Doch neuerdings klappt es - in der Win-Version - relativ häufig NICHT.

Symptom:
Nach dem Kopieren aus dem Formelbereich ist das normale Einfügen zwar ausgegraut - und es wird nur das "NEUE" Inhalte Einfügen angeboten - das hier leider, leider nur noch eine Auswahl zwischen nur Text, nur Zahlen, nur Formeln bietet. Allerdings sind alle 3 Optionen ausgegraut und funktionieren AUCH NICHT. Dafür aber funktioniert das (eigentlich nicht verfügbare) normale Einfügen - natürlich mit dem Nachteil, dass die kopierten Zellen eben samt Formeln und Formatierung übertragen werden - WAS beliebige Probleme verursacht, sofern die Auswertetabelle nicht gänzlich auf absolute Bezüge gestellt ist (was bei größeren Bereich nervtötend und zeitraubend sein kann - grade wenn man Auswerteformeln häufig modifziert und die Modifikationen per Bereiche ausfüllen auf die gesamte Auswerte-Tabelle überträgt).
Besonders SCHLIMM daran: Neben den Inkonsistenzen im Menu (graue Funktionen sollten nicht funktionieren... ) erinnere ich mich, dass das oft auch geklappt hat, nur eben manchmal nicht. Woran das nun genau liegt, konnte ich noch nicht eruieren...

Als an sich treuer Fan von Calc frage ich mich nun ernsthaft, was soll sowas? Das NEUE Als Inhalte EInfügen wäre m.A.n. selbst dann kaum brauchbar, wenn es funktionieren würde. Da war die alte Implemenation - bei Inhalte Einfügen öffnete sich ein Fenster, in dem man präzise festlegen konnte WAS genau eingefügt werden soll, deutlich zweckmäßiger - zumal sie auch zuverlässig genau das tat, was man von ihr verlangte. So ließen sich z.B. sogar aufwändige Formatierungen (ganz ohne Inhalte) transferien u.v.m. Hier stehen wir also vor einem bedeutenden RÜCKSCHRITT in der Funktionalität - und obendrein offenbar auch noch vor einem Bug (der die amputierte Funktionalität allerdings nicht beheben kann...).

Sicher ist es toll, wenn ein (eh schon gutes...) Programm verbessert wird - aber wieso fummelt man hier an Funktionalitäten herum, die erstens funktionieren und sich zweitens sehr bewährt haben? Sollte hier Verinfachung das Ziel gewesen sein, dann rate ich dringend dazu, man in sich zu gehen. Derart grundlegende Änderungen dürften nicht nur meine Workflows mit enormen Mengen bestehenden Materials durcheinander wirbeln - sowas kostet Zeit und Nerven ohne Ende.

Ich jedenfalls kann und werde die Arbeit mit LO-Calc in diesem Zustand leider NIEMANDEM mehr empfehlen...
Wie das ganze auf Linux ausschaut, habe ich noch nicht untersucht (hab auch noch anderes zu tun...). Da dort die Versionen oft älter sind, dürfte es dieses Problem dort vermutlich NOCH nicht geben - und damit ist auch der Workaround klar:
Alte Versionen benutzen, vielleicht auf OO umsteigen etc... Solange zumindest, bis man mit LO wieder unter irgendwie planbaren Bedingungen arbeiten kann.
Damit das ganze jetzt nicht zu frustiert rüber kommt: gelegentliche Ausflüge in Excel meiern mich oft noch weitaus mehr an. Da scheint das Verspacken logisch eigentlich klarer Funktionalitäten geradezu zum Prinzip erhoben zu sein.
Es wäre echt toll, wenn LO darauf verzichtet, Excel in dieser Hinsicht nachzueifern...

JosuaKylie

Re: Formeln kopieren und Inhalte einfügen geht nicht mehr

Beitrag von JosuaKylie » So, 13.05.2018 08:51

Sorry.. ich seh grad dass ich Tab-Trouble im Browser hatte - und aus Versehen im OO-Forum statt im LO-Forum gelandet bin.
However - jedenfalls besteht das gleiche Problem und ich bin entsetzt, dass das offenbar AUCH OO betrifft.
Na - wenn das mal ein Zufall ist...


Antworten