Fehler beim Schreiben des Teildokuments styles.xml

Das Textverarbeitungsprogramm

Moderator: Moderatoren

HansS
Beiträge: 2
Registriert: Do, 10.10.2019 14:32

Fehler beim Schreiben des Teildokuments styles.xml

Beitrag von HansS » Do, 10.10.2019 14:52

Ich versuche gerade den Übergang von Word für Windows 2.0 (Windows 3.11) auf Open Office hinzubekommen. Bisher läuft das ganz gut. Open Office kann die alten Dateien im Prinzip lesen, ich muss aber die Formate noch von Hand mühsam nacharbeiten. Nun stehe ich vor einem ganz blöden aber grundsätzlichen Problem: Nachdem ich eine Datei bearbeitet habe, will ich sie auf meiner externen Festplatte als ODT speichern. Und da sagt mir nun der Writer:
---------
Fehler beim Speichern des Dokumentes *****:
Schreibfehler.
Fehler beim Schreiben des Teildokuments styles.xml.
[OK]
----------

Es handelt sich um eine nicht allzu große Datei, ohne irgendwelchen Schnickschnack, außer dass ich die Schrift eingestellt habe, die Einzüge rechts und links etwas variieren, um alles in Form zu bringen.

Erst wenn ich das soweit hinbekomme, komme ich zu den weiteren Schritten. Dann möchte ich bei einigen Vorlagen Hintergrundgrafiken einbinden, bei anderen jpg-Grafiken hinter dem Text einbinden. Dann will ich auch noch Makros entwickeln, um bestimmte Datenübernahmen zu automatisieren. Aber erstmal muss ich überhaupt sicher speichern können.

Stephan
********
Beiträge: 11239
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: Fehler beim Schreiben des Teildokuments styles.xml

Beitrag von Stephan » Do, 10.10.2019 15:16

Ja, Word kann doc ziemlich gut lesen, aber nicht perfekt, ich denke deutlich besser als 95%ig im Durchschnitt. In Praxis läuft das aber darauf hinaus das verschiedene Dateien verschieden gut gelesen werden, manche zu 100% perfekt, aber Einzelne auch viel schlechter. Die Formate nacharbeiten zu müssen ist kein generelles Problem, tritt aber auf.
---------
Fehler beim Speichern des Dokumentes *****:
Schreibfehler.
Fehler beim Schreiben des Teildokuments styles.xml.
[OK]
----------
Das sollte nicht passieren. Mir ist klar was der Fehler meint, aber was die konkrete Ursache ist kann ich nicht pauschal sagen, Das Internet meint u.a.:

-Dein Speichermedium könnte fast voll sein
-in den Absatzformatierungen ist "Registerhaltigkeit" aktiviert, was irgendwie das Speichern stört
-es wird empfohlen eine neue Datei zu öffnen und den Inhalt der bestehenden Datei über Einfügen-Datei einzufügen und dann zu Speichern


Vielleicht haben andere hier noch mehr Ideen/Vorschläge.


Gruß
Stephan

Benutzeravatar
Faol
****
Beiträge: 140
Registriert: Di, 26.01.2016 21:18

Re: Fehler beim Schreiben des Teildokuments styles.xml

Beitrag von Faol » Do, 10.10.2019 18:42

Hallo Hans,

ich kenne zwar den Fehler, aber es ist jenach Dokument recht
schwierig die Datei styles.xml wieder zu rekonstruieren.

Ich denke, dass es einfacher und sauberer ist, den Inhalt Deiner Dateien
einfach in eine neue Datei zu kopieren, als die alten Dateien zu konvertieren.
  1. alte Datei öffnen
  2. Tastenkombination --> [STRG]+[a]
  3. Tastenkombination --> [STRG]+[c]
  4. Neue ODT-Datei öffnen
  5. Tastenkombination --> [STRG]+[v]
  6. Nun die Formatierung ggf. anpassen
Vorteil:
Du handelst Dir keine Konvertierungsfehler ein.
Gruß
Faol
⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒
Win.10 Prof. (x64) • AOO 4.1.6 • LibO 6.3.1.2 (x64)
⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐

HansS
Beiträge: 2
Registriert: Do, 10.10.2019 14:32

Re: Fehler beim Schreiben des Teildokuments styles.xml

Beitrag von HansS » Mi, 16.10.2019 14:15

Vielen Dank Faol. Ich mache das jetzt so, auch wenn ich es etwas unbefriedigend finde.

Nun stellt sich das nächste nervige Problem: Automatische Formatierungen. Mit diesem zweifelhaften Luxus hatte ich unter Winword 2.0 nicht zu kämpfen. Da macht das Programm zum Glück nur, was es ausdrücklich tun soll, ohne zu meinen, alles besser zu wissen als der User.

Am Liebsten würde ich zunächst einmal das Feature für allgemeine Texte beibehalten, aber für eine Kategorie von Vorlagen vollständig deaktivieren. Ich bekomme derzeit immer wenn ich die Absatz (Enter)-Taste drücke einen hängenden Einzug. Weiß jemand, wie ich das für eine Vorlage und alle von dieser Vorlage abgeleiteten Vorlagen abstellen kann? Notfalls, wie ich diese ganze Autokorrekturfunktion abstellen kann?

Benutzeravatar
Faol
****
Beiträge: 140
Registriert: Di, 26.01.2016 21:18

Re: Fehler beim Schreiben des Teildokuments styles.xml

Beitrag von Faol » Mi, 16.10.2019 15:41

Hallo Hans,
Hans hat geschrieben:Ich mache das jetzt so, auch wenn ich es etwas unbefriedigend finde.
Letztendlich ist dies die beste und einfachste Option.
  1. Konvertierungsfehler werden damit ausgemerzt und somit sind ggf. weitere Fehler ausgeschlossen.
  2. Man kann auch das odt-File entpacken und die xml-Files manipulieren,
    dies ist aber wesentlich aufwendiger, als mein Lösungvorschlag.
Hans hat geschrieben:Automatische Formatierungen. Mit diesem zweifelhaften Luxus hatte ich unter Winword 2.0 nicht zu kämpfen. Da macht das Programm zum Glück nur, was es ausdrücklich tun soll, ohne zu meinen, alles besser zu wissen als der User.
Winword 2.0 kenne ich nicht, habe erst mit Word 6.0 angefangen und
selbst hier gab es schon "automatische Formatierungen", bzw. Formatvorlagen.
Diese habe ich ausgiebig und gern benutzt, denn bei richtiger Anwendung bieten
diese erhebliche Vorteile, besonders bei umfangreichen Dokumenten.

Einen zweifelhaften Luxus sehe ich darin nicht, man muss dem System nur mitteilen
was man will und schon ist man wieder Herr der Lage und Chef des Systems.
Wie gesagt bei richtiger Anwendung der verschiedenen Vorlagen, welches selbstverständlich
einiges an Wissen voraussetzt, ist dies kein Luxus, sondern sehr nützlich.
Hans hat geschrieben:Am Liebsten würde ich zunächst einmal das Feature für allgemeine Texte beibehalten, aber für eine Kategorie von Vorlagen vollständig deaktivieren.
Vollständig oder teilsweise deaktivieren geht nicht.
Der Vorlagen-Automatismus ist Bestandteil eines jeden modernen Textverarbeitungsprogramms.
Sonst, ganz wie der Chef des Systems es wünscht... :lol:
Eckigen Klammern = Tastenkombinationen
  1. Alles markieren
    [STRG]+[a]
  2. Formatvorlagen-Fenster öffnen
    [F11]
  3. Suche in Fenster "Standard-Vorlage" oder "Textkörper-Vorlage"
    Maus Doppelklick
  4. Nun ist alles auf "Standard" oder "Textkörper" gesetzt.
  5. egal wo Du nun Deine Cursor im Dokument plazierst, siehst Du in der Sysmbolleiste,
    links neben der Anzeige für die verwendete Schriftart "Standard" oder "Textkörper"
Nun kann für das gesamte Dokument dies Vorlage geändert werden:
Hans hat geschrieben:Ich bekomme derzeit immer wenn ich die Absatz (Enter)-Taste drücke einen hängenden Einzug. Weiß jemand, wie ich das für eine Vorlage und alle von dieser Vorlage abgeleiteten Vorlagen abstellen kann? Notfalls, wie ich diese ganze Autokorrekturfunktion abstellen kann?
  1. Im noch geöffneten Vorlagen-Fenster die für Dein Dokument, im vorherigen
    Schritt zugewiesen Vorlagen (Standard oder Textkörper) auswählen.
  2. Mit Rechtsklick das Kontextmenü öffnen
  3. "Ändern..." auswählen
  4. Im sich öffnenden Fenster unter "Einzüge und Abstände" die gewünschten Maße eingeben.
  5. Mit OK bestätigen
Nun sollte das gesamte Dokument Deinen wünschen entsprechen.
Wenn nicht, dann ggf. nochmals alles markieren ([STRG]+[a]) und
per Doppelklick im Vorlagen-Fenster auf "Standard" oder "Textkörper"
klicken, abhängig davon was Du gerade bearbeitet hast.

PS
Statt mit dem Vorlagenfenster zu arbeiten, kannst Du auch die Sidebar öffnen.
Suche ganz rechts das Symbol "Formatvorlagen" und aktiviere es.

Siehe auch:
http://prooo-box.org/live/seiten/dokumentation.html
https://www.youtube.com/watch?v=ZwFwVTvIYSc
https://wiki.openoffice.org/wiki/DE/Dok ... _erstellen
Gruß
Faol
⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒
Win.10 Prof. (x64) • AOO 4.1.6 • LibO 6.3.1.2 (x64)
⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐

Eddy
********
Beiträge: 2617
Registriert: So, 02.10.2005 10:14

Re: Fehler beim Schreiben des Teildokuments styles.xml

Beitrag von Eddy » Mi, 16.10.2019 17:52

Hallo HansS,
HansS hat geschrieben:
Mi, 16.10.2019 14:15
Notfalls, wie ich diese ganze Autokorrekturfunktion abstellen kann?
Bei Extras > Autokorrektur die Markierung bei "Während der Eingabe" entfernen.

Wenn das Deine Formatierungsprobleme nicht löst, eröffne bitte einen neuen Thread.

Antworten