SUMMEWENN über mehrere Tabellen

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Mephisto-123
Beiträge: 4
Registriert: Di, 17.05.2022 01:40

SUMMEWENN über mehrere Tabellen

Beitrag von Mephisto-123 »

Hallo,

ist es möglich, Werte aus einem bestimmten Feld, von mehreren Tabellen zu summieren, angeknüpft an eine Bedingung?
Heißt: Ich möchte beispielsweise über 10 Tabellen jeweils die Felder B3 summieren, wenn deren Werte positiv (also größer 0 sind).
Meine Formel dazu lautet: =SUMMEWENN(Tabelle1.B3:Tabelle10.B3;">0")
Leider erhalte ich da aber nur den Fehler ERR:504.
Kann da jemand helfen?

Beste Grüße
Karolus
********
Beiträge: 7183
Registriert: Mo, 02.01.2006 19:48

Re: SUMMEWENN über mehrere Tabellen

Beitrag von Karolus »

Hallo
Geht nicht!
Zerfleddere halt nicht deine eigentlich zusammengehörenden Daten, indem du sie unnötigerweise auf drölfzig Tabellen verteilst.
Version: 6.1.5.2
Build-ID: 1:6.1.5-3+rpi1+deb10u6+rpt1
raspberry-pi-OS
Mephisto-123
Beiträge: 4
Registriert: Di, 17.05.2022 01:40

Re: SUMMEWENN über mehrere Tabellen

Beitrag von Mephisto-123 »

Hallo,

Danke für deine schnelle Antwort.
Allerdings hat das so schon seine Richtigkeit mit den drölfzig Tabellen! ;)
Dann muss ich mir leider was anderes einfallen lassen!
craig22
****
Beiträge: 128
Registriert: Mi, 19.08.2020 13:47

Re: SUMMEWENN über mehrere Tabellen

Beitrag von craig22 »

Hallo,

eine simple Lösung mit HIlfstabelle:
Summewenn mit Hilfstabelle.ods
(9.42 KiB) 29-mal heruntergeladen
Gruß

Craig
_____________________________________________________
WIN 10 Pro 64-Bit • LO 7.1.5.2 (x64) • AOO 4.1.8
Mephisto-123
Beiträge: 4
Registriert: Di, 17.05.2022 01:40

Re: SUMMEWENN über mehrere Tabellen

Beitrag von Mephisto-123 »

Danke dir!!
Die Lösung mit der Hilfstabelle klappt prima! 8)

Frage dazu aber: auf welchen "Wert" bezieht sich die 3. "2" in der Funktion?
=INDIREKT(ADRESSE(3;2;2;;A2))

Also: =INDIREKT(ADRESSE(Zeile;Spalte;?;;Bezugstabelle))

Das habe ich noch nicht ganz durchblickt ^^
craig22
****
Beiträge: 128
Registriert: Mi, 19.08.2020 13:47

Re: SUMMEWENN über mehrere Tabellen

Beitrag von craig22 »

Hallo,
Die AOO-Hilfe hat geschrieben: Syntax
ADRESSE(Zeile; Spalte; Abs; A1;"Tabelle")
Zeile stellt die Zeilennummer für den Zellbezug dar.
Spalte stellt die Spaltenzahl für den Zellbezug dar (die Zahl, nicht den Buchstaben).
Abs bestimmt den Bezugstyp:
1 oder leer: Absolut ($A$1)
2: Zeile absolut; Spalte relativ (A$1)
3: Zeile relativ; Spalte absolut ($A1)
4: Relativ (A1)
Wenn A1 (optional) auf 0 gesetzt ist, wird die R1C1 Notation verwendet. Wenn dieser Parameter fehlt, oder einen anderen Wert als 0 hat, wird die A1 Notation verwendet.
Tabelle stellt den Namen der Tabelle dar. Er muss in doppelten Anführungszeichen stehen.
Gruß

Craig
_____________________________________________________
WIN 10 Pro 64-Bit • LO 7.1.5.2 (x64) • AOO 4.1.8
Mephisto-123
Beiträge: 4
Registriert: Di, 17.05.2022 01:40

Re: SUMMEWENN über mehrere Tabellen

Beitrag von Mephisto-123 »

Super, danke euch! :)

Beste Grüße
Karolus
********
Beiträge: 7183
Registriert: Mo, 02.01.2006 19:48

Re: SUMMEWENN über mehrere Tabellen

Beitrag von Karolus »

Wobei es im Kontext mit INDIREKT vollkommen egal ist ob man da relative|absolute Bezüge rausgibt…genausogut tuts ein einfaches:

Code: Alles auswählen

=INDIREKT(A2 & ".B3")
Version: 6.1.5.2
Build-ID: 1:6.1.5-3+rpi1+deb10u6+rpt1
raspberry-pi-OS
Helmut_S
****
Beiträge: 186
Registriert: So, 29.10.2017 11:29

Re: SUMMEWENN über mehrere Tabellen

Beitrag von Helmut_S »

Hallo Mephisto... , anbei noch ein Vorschlag, ohne indirekt() und Hilfstabelle.
Falls deine Frage beantwortet wurde, solltest du den Thread als [gelöst] kennzeichnen.
Gruß Helmut
Dateianhänge
Summewenn_ohne_Hilfstabelle.ods
(13.4 KiB) 24-mal heruntergeladen
MX-Linux 21 KDE, Linux Mint 20.3 Cinnamon
cwolan
**
Beiträge: 25
Registriert: Sa, 06.03.2021 12:56

Re: SUMMEWENN über mehrere Tabellen

Beitrag von cwolan »

Hallo,

@Helmut_S

Vielleicht kann Deine Formel gekürzt werden?

Code: Alles auswählen

=SUMMEWENN(eins~zwei~drei~vier~fuenf~sechs~sieben~acht~Neun~zehn;">5")
Gruß Czesław
Win. 7, 10 (x64) ▪ LO 7.2.7.2 ▪ AOO 4.1.12 und einige ältere Versionen
Helmut_S
****
Beiträge: 186
Registriert: So, 29.10.2017 11:29

Re: SUMMEWENN über mehrere Tabellen

Beitrag von Helmut_S »

Hallo @cvolan, perfekt ! So ist die Formel elegant und übersichtlich!
Gruß Helmut
MX-Linux 21 KDE, Linux Mint 20.3 Cinnamon
Antworten